ilreme's blog :: 'SRT' 태그의 글 목록

'SRT'에 대한 글 검색 결과 1개search result for posts

QNAP NAS에서 SMI 자막 제대로 보기

블로깅 어체가 뭐였는지 까먹어서 예전 글들을 다시 봐야 할 만큼

정말 오랜만에 포스팅이에요.

 

최근 방 이곳 저곳을 뒹굴던 LG전자 빔프로젝터 PA75A를 천장에 설치 하면서 
집에서 개발 소스 버젼관리용과 DXD, SACD 등 HD음원 저장하던 NAS 2대 (QNAP 269Pro, 

Synology 412+ ) 중 한대를 영화 및 재생 전용으로 셋팅 하는데 NAS의 DLNA 자막 지원에 대한

제대로 된 정보가 없어서 포스팅 해요.

 

이 포스팅까지 오신분들이라면 아시겠지만..

QNAP 기본 제공하는 DLNA 미디어 서버 와 TwonkyMedia DLNA는 SMI, SRT 자막을 제대로 지원하지

못해요. 하지만 다음과 같이 설치하고 나면 MKV소스까지 문제 없이 감상이 가능 합니다! 야호!

 

준비물

1.  JRE_7.qpkg: JRE 설치용 QPKG 파일

2. ejre-7u45-fcs-b15-linux-i586-headless-26_sep_2013.tar.gz : x86 embedded 리눅스용 JRE

   - 링크에 가셔서 x86 Linux Small Footprint – Headless을 다운로드, 

     이전 Sun 시절에는 로그인 없이 다운로드 되었던것 같은데 Oracle로 인수되고 로그인도 하게 하네요. 

3. Serviio_1.3.1-Rev1_x86.qpkg : Serviio QPKG 파일 x86용

   - arm 계열을 사용하시는 분은 http://forum.qnap.com/viewtopic.php?f=252&t=84702 이곳에서

 

 

설치!

 

1. JRE ejre-7u45-fcs-b15-linux-i586-headless-26_sep_2013.tar.gz 를 QNAP NAS 폴더에 복사

 

 

2. QNAP Appcenter 에서 JRE_7.qpkg 수동설치

 

 

3. 설치가 완료 되면 JRE 을 On으로 활성화

 

 

3. QNAP Appcenter 에서 Serviio (Serviio_1.3.1-Rev1_x86.qpkg) 수동 설치

 

 

설정!

 

1. Serviio 에서 시작 클릭

 

 

2. Serviio 설정

- Status Renderer Profile 에서 DLNA 대상에 대해서 Profile 변경

  . 저는 LG 빔프로젝터를 사용하고 있으므로 Generic DLNA profile -> LG TV / Player 로 설정 했어요.

    LG 외에도 본인이 가진 제품의 회사 (필립스, 소니 및 기타 삼성 등) 것으로 변경이 가능 해요.

- Library 탭에서 영화가 있는 폴더 선택

- Delivery 탭에서 General settings의 Transcoded files location을 /root/.serviio/tmp 으로 변경

- Metadata 에서 Preferred Language 를 한국어 로 설정

- 모든 탭에서 설정을 하면 꼭 Save를 해주세요

- 모든 설정이 완료 되면 Start server 를 해주면 끝!

 

 

모든 설정이 완료 되면 QNAP에서 DLNA 미디어 서버 와 TwonkyMedia DLNA 는 다 꺼주시는게 좋아요 ^-^/

 

  • 비밀댓글입니다
  • 하이호이2014.03.31 23:59 수정/삭제 댓글주소 댓글달기
    안녕하세요. 보고 따라해보려고 하는데 오류가 발생하여 질문드립니다.

    사용 장비는 TS-212입니다.

    JRE7을 설치하려 하였는데

    JRE7 installation failed. Java Embedded installation archive file not found under /share/Public.

    라고 나오네요. 블로그에서 링크 가서 받은 2번 파일은 NAS 내에 존재하는 public 폴더에 들어있습니다.

    그래서 JRE 설치가 되지 않아 앱 샌터에 가봤는데 그곳에 JRE가 있더군요.

    그곳에서 설치를 하고 보니 JRE 7버전인데

    Serviio 설치시

    Serviio 1.4.1.2-R1 installation failed. The following QPKG must be installed and enabled:JRE>=6.

    라고 오류가 발생을 하네요.

    3번은 ARM 계열로 받아놓은 상태입니다.

    혹시 어떤 것을 확인해보는것이 좋을까요?




페이지 이동< 1 >